Kubuntu 22.04.3 - EasyConnect Problem 100

ThomasC Lv1Posted 03 Sep 2023 17:12

Good morning,
   I have a problem with EasyConnect (; I've downloaded the .deb from the SSLVPN page of our firewall, installed it, but it seems that the client doesn not start at all.

Viewing on the journal of the system I've come across this error:

   general protection fault in libharfbuzz.so.0.20704.0

I've tried using old libraries of libpango (1.44.7 and 1.50.6+ds2) but I'm not able to resolve this issue; the system it's a freshly installed Kubuntu 22.04.3.

Can you help me?


KY has solved this question and earned 10 coins.

Posting a reply earns you 2 coins. An accepted reply earns you 20 coins, 100 coins of bounty and another 10 coins for replying within 10 minutes. (Expired) What is Coin?

Enter your mobile phone number and company name for better service. Go

For your information, EasyConnect currently officially supports Ubuntu versions up to 18.04.1. The server version is currently not supported to install EasyConnect.
Is this answer helpful?
RegiBoy Lv5Posted 04 Sep 2023 14:22
Is your issues related to Sangfor?
ThomasC Lv1Posted 04 Sep 2023 15:08
Yes, the issue it's related to the EasyConnect client of our NGAF client.
NeTSec Lv3Posted 04 Sep 2023 15:58
I think you should contact the Sangfor Support Team. I am not familiar with the Kubuntu
Farina Ahmed Posted 05 Sep 2023 13:28
The error message you're encountering, "general protection fault in libharfbuzz.so.0.20704.0," indicates a problem with the libharfbuzz library, which is used for text shaping and rendering. This issue may be related to library compatibility or a bug in the EasyConnect VPN client.

Here are some steps you can take to troubleshoot and potentially resolve this issue:

Check for Updated EasyConnect Client:
Ensure that you have the latest version of the EasyConnect client. Visit the SSLVPN page of your firewall to see if there's a newer version available for download. Sometimes, software updates include bug fixes and compatibility improvements.

Library Compatibility:
It's good that you've tried using older versions of libpango, but you may also want to check the compatibility of libharfbuzz with your system. It's possible that the EasyConnect client is not compatible with the version of libharfbuzz provided by Kubuntu 22.04.3.

Dependency Issues:
Review the system requirements and dependencies for the EasyConnect client. Make sure you have all the necessary libraries and packages installed on your Kubuntu system. You might need to install additional packages to satisfy the client's dependencies.

Run EasyConnect in Compatibility Mode:
You can try running the EasyConnect client in compatibility mode, which may help with library compatibility issues. To do this, open a terminal and run the following command, replacing /path/to/easyconnect with the actual path to the EasyConnect executable:

LD_LIBRARY_PATH=/path/to/easyconnect /path/to/easyconnect
This sets the library path to the location of the EasyConnect client, which may help it find the required libraries.

Check for Logs:
Review the logs generated by the EasyConnect client itself. The client may produce its own log files in a specific directory. Look for any error messages or hints in these logs that could help diagnose the issue.

Contact Support:
If none of the above steps resolve the issue, consider reaching out to the support provided by the vendor of your firewall or VPN client. They may be aware of the issue and have specific guidance or a solution for Kubuntu 22.04.3.

Consider Using Alternative VPN Clients:
If you continue to encounter problems with EasyConnect, you might consider using an alternative VPN client that is known to work well with your Kubuntu version. OpenConnect and AnyConnect are popular VPN clients that are often used in Linux environments.

Remember to back up any important data and configurations before making significant changes to your system, and be cautious when making changes to library versions to avoid causing system instability.
Faixan Lv1Posted 05 Sep 2023 15:04

I can help you with that. Here are some things you can try to fix the EasyConnect problem on Kubuntu 22.04.3:

Make sure that EasyConnect is installed. You can do this by opening a terminal and running the following command:
sudo apt install easyconnect
Check the EasyConnect settings. Open the EasyConnect settings by clicking on the Activities button and searching for "EasyConnect". Make sure that the "Enable EasyConnect" checkbox is checked.

Restart your computer. Sometimes a simple restart can fix the problem.

Disable SELinux. SELinux is a security feature that can sometimes interfere with EasyConnect. To disable SELinux, open a terminal and run the following command:

sudo setenforce 0
Reinstall EasyConnect. If all else fails, you can try reinstalling EasyConnect. To do this, open a terminal and run the following command:
sudo apt remove easyconnect
sudo apt install easyconnect
If you are still having problems with EasyConnect, you can contact Sangfor support for help.

Here are some additional things to keep in mind:

EasyConnect requires a working internet connection.
EasyConnect may not work if you are using a VPN.
EasyConnect may not work if you are using a proxy server.
Kuripot Sangfor Lv1Posted 05 Sep 2023 20:29
Try to collaborate with it specialist
Beru Lv2Posted 06 Sep 2023 09:57
Last edited by Beru 06 Sep 2023 09:58.

Here are some steps you can try to resolve this issue:

Check Dependencies: Ensure that you have all the required dependencies installed. EasyConnect may rely on certain libraries or packages that are not automatically installed with the .deb package.

Update Libraries: Make sure that your system libraries are up to date. You can update your system libraries.

Contact Support: If the issue persists, consider reaching out to Sangfor support team. They may have specific guidance or a solution for this problem.
Zonger Lv4Posted 06 Sep 2023 16:23
The "general protection fault in libharfbuzz.so.0.20704.0" error you're encountering with Sangfor EasyConnect on a freshly installed Kubuntu 22.04.3 is likely due to a library compatibility issue.
  • Check Dependencies: Ensure that all required dependencies for Sangfor EasyConnect are installed on your system. You can often find dependency information on the software's download page or in its documentation.
  • Library Compatibility: Verify that the version of libharfbuzz.so.0 you have is compatible with your version of Kubuntu. Sometimes, using a library version that matches your system's libraries can resolve compatibility issues.
  • Install Missing Libraries: Use your package manager to check for and install any missing or required libraries. For example, you can use the apt package manager to search for and install missing libraries.
    [backcolor=rgba(0,0,0,var(--tw-bg-opacity))][color=rgba(217,217,227,var(--tw-text-opacity))][backcolor=rgba(52,53,65,var(--tw-bg-opacity))][size=0.75]bashCopy code
    sudo apt update sudo apt search libharfbuzz

    Then, install any missing libraries using sudo apt install libharfbuzz.
  • Library Path: Check the library search path. Ensure that the directory containing the required libraries is in your system's library path. You can check the library path using:
    [backcolor=rgba(0,0,0,var(--tw-bg-opacity))][color=rgba(217,217,227,var(--tw-text-opacity))][backcolor=rgba(52,53,65,var(--tw-bg-opacity))][size=0.75]bashCopy code

    If it's not set correctly, you can set it temporarily using:
    [backcolor=rgba(0,0,0,var(--tw-bg-opacity))][color=rgba(217,217,227,var(--tw-text-opacity))][backcolor=rgba(52,53,65,var(--tw-bg-opacity))][size=0.75]bashCopy code
    export LD_LIBRARY_PATH=/path/to/library/directory

    Replace /path/to/library/directory with the actual path to the directory containing the required libraries.
  • 64-bit vs. 32-bit: Ensure that you have the correct architecture of the libraries installed. If Sangfor EasyConnect is a 32-bit application, you may need to install 32-bit versions of the required libraries.
  • Reinstallation: Try uninstalling Sangfor EasyConnect, then reinstalling it to ensure that all necessary components are properly installed.

Kuripot Sangfor Lv1Posted 07 Sep 2023 20:52
Thank you for info

I Can Help:


Board Leaders