rout has turnd invalid

haiha298 Lv1Posted 06 Jan 2020 14:07

I have 2 WAN, so i have 1 WAN often send for me this noticed.:"The link on the interface(eth0) has failed, and therefore, the following associated route has turned invalid: dst[0.0.0.0] netmask[0.0.0.0] gateway[x.x.x.x] dev[eth0] metric[1]"". How can i fix this, thank you so much

rivsy has solved this question and earned 10 coins.

Posting a reply earns you 2 coins. An accepted reply earns you 20 coins and another 10 coins for replying within 10 minutes. (Expired) What is Coin?

Enter your mobile phone number and company name for better service. Go

1. In the network interface, Click WAN link
2. On the bottom click Link state Detection Settings
3. Enable, then click PING and set Destination IP 1 (input gateway IP of ISP)
4. After Configuring Link state detection of your WAN Links
-  You can see the state of it if its Normal or at Fault
5. After setting the link state detection, Go to Network > Routing > Policy Based Routing then add Link Load
Balancing Route.
-  Network Objects > ALL
-  Add interface of WAN Links for failover

Please see below picture for reference of the steps
wan1.png
wan2.png
wan3.png
wan4.png
wan5.png
Is this answer helpful?
Bakhtiar Lv3Posted 06 Jan 2020 15:49
  
usually Eth0 is used for local, are you sure that eth0 is going to WAN ?
rivsy Lv4Posted 06 Jun 2022 13:58
  
1. In the network interface, Click WAN link
2. On the bottom click Link state Detection Settings
3. Enable, then click PING and set Destination IP 1 (input gateway IP of ISP)
4. After Configuring Link state detection of your WAN Links
-  You can see the state of it if its Normal or at Fault
5. After setting the link state detection, Go to Network > Routing > Policy Based Routing then add Link Load
Balancing Route.
-  Network Objects > ALL
-  Add interface of WAN Links for failover

Please see below picture for reference of the steps
wan1.png
wan2.png
wan3.png
wan4.png
wan5.png
jetjetd Lv5Posted 06 Jun 2022 14:28
  
If you have 2 WAN links, I recommend to configure Link Load Balancing to maximize the use of your 2 WAN links.
Faisal P Lv8Posted 06 Jun 2022 14:39
  
You can specify an internal static IP for the instance at the time of creation.
KatAndres Lv2Posted 07 Jun 2022 13:33
  
If you have 2 WAN links, I recommend to configure Link Load Balancing to maximize the use of your 2 WAN links.
Imran Tahir Lv4Posted 07 Jun 2022 14:05
  
we have two links and we have configure link load balancing
regidorreyes Lv4Posted 08 Jun 2022 06:05
  
the solution is  simple. configure load balancing
Osama Muhammad Lv3Posted 08 Jun 2022 23:12
  
enabling link state detection send you these notification, you need to check your interface link.
Farina Ahmed Lv3Posted 09 Jun 2022 14:08
  
You need load balancing, like two ISPs and also you have to assigned virtual gateway in all end users so the end user didn't effect while one link is down. You don't need to have manually changing gateways in all end devices for that reason use a virtual IP.

I Can Help:

Change

Moderator on This Board

1
85
3

Started Topics

Followers

Follow

Board Leaders