NGAF upgrade failed, cause the web UI cannot login

|
  • 77
  • 0

Issue Description

The firmware upgrade of the NGAF is failed and the device has been reboot. After reboot the device remained at the same firmware version but unable to login. An error message You have no permission is prompt.

Error/Warning Information

Tried to use the admin account to login but the error message You have no permission is prompt.

Handling Process

1. Prepare a Laptop conenct to the management interface of the NGAF.
2. Using the telnet to verify does the port 22345 of the management interface is up.
3. If the telnet is success, connect to the backend of the NGAF using management interface.
4. Prepare the firmware upgrade file.

Root Cause

The issue is cause by the previous firmware upgrade is failed.

Solution

1. Extract the NGAF firmware upgrade file.
The password of the file is sangforupd~!@#$%
*Please remember not to share the password with external and remember to delete the files once the operation is complete*

Extracted firmware file, we can observe that there is total of 8 upgrade package.

2. Verify the update log.
/etc/pr/gcs/gcs_update_detail.log

Based on the log identified that the during previous firmware upgrade the sixth package is installed sucessfully.

3. Copy the app7 package and upload to the /stmp on the NGAF, and rename app7 to app.

4. Copy the appsh7 package and upload to the/etc/dlancmd/ on the NGAF and rename appsh7 to appsh.

5. May observe the installation of the package from the following log.
/etc/pr/gcs/gcs_update_detail.log

6. Repeat the Step3 until all the left over packages is installed.

7. After all the package is installed, require to reboot the NGAF.

Suggestions

1. Required to inform the user that the NGAF need to be reboot when the activity is complete.
2. After the activity is complete, remember to delete extracted package.

I want to write a case
Doc ID: 9227
Author: Ted3
Updated: 2023-09-07 19:02
Version: