Unable to import csv file on user binding/local users

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Issue Description

Unable to import csv file on user binding/local users. Prompt message: Import n entries successfully, n entries failed.

Handling Process

1. Try to export existing users, able to export successfully.
2. Import again the csv file that just exported without doing any modification, able to import all successfully.
3. Use Microsoft Excel to open the csv file and save it, but does not make any modification. Import again and the message prompt out.
4. Check the csv file, found out that the expiry date format needed by IAM (yyyy-mm-dd) does not match with the user’s date format (m/dd/yyyy).

Root Cause

The expiry date format needed by IAM (yyyy-mm-dd) does not match with the user’s date format. Due to Microsoft Excel behavior, when saving the csv file, the date will automatically be converted to another format.

Solution

Use another spreadsheet software that will not change the date format. Or use another software (e.g: notepad) to edit the date format to match the IAM required date format.
Or in excel, right click on the date column and click Format cells:
Select the date format (e.g: English [Canada] – 2012-03-14) which matched the IAM required date format:
After selected the correct date format, can proceed to save in excel and import to IAM.



Faisal Posted 08 Aug 2021 10:56
  
Thank you very much for the information ...
Faisal Posted 08 Aug 2021 10:56
  
Nice article ...
Faisal Posted 08 Aug 2021 10:57
  
Great info ...
Faisal Posted 08 Aug 2021 10:57
  
Very informative ...
Ellechar Lv4Posted 11 Aug 2021 09:09
  
Very nice article!
faizansami Lv2Posted 19 Jan 2022 13:23
  
Very nice article!
Raza Islam Lv3Posted 07 Jul 2022 18:37
  
Thank you very much for the information.
Raza Islam Lv3Posted 13 Jul 2022 15:16
  
Nice guidance
Raza Islam Lv3Posted 25 Jul 2022 16:12
  
Nice guidance.

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Doc ID: 3134
Author: Sangfor_Brando
Updated: 2021-08-07 06:22
Version: