Unable to launch Antivirus program on Shared Desktop

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Issue Description

Launching the antivirus program on shared desktop has no effect. RDP to the server and launch Antivirus is normal. We can determine that the program is abnormal when access using VDI shared desktop.

Error/Warning Information

View on task manager, the antirus program in shared desktop is abnormal.

Handling Process

1. On the task manager, right click on the process and select 'open file location'.
2.Try launch the .exe and prompts error.
3.Go to Registry and create a new string under the registry:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sangfor\SSL\RemoteAppServer\RemoteAppApiHook\NotHookExeName
Note: New string value is the name of the .exe used by the Antivirus program. (.exe extension must be included)

Root Cause

1. Conflicts with VDI service, add into registry to whitelist the program.

Solution

Add all .exe used by the antivirus program into 'NotHookExeName' list to avoid any conflicts with VDI service.
Muhammad Bilal Lv4Posted 15 Jan 2021 00:55
  
Thanks for sharing information
Faisal Posted 19 Feb 2021 21:17
  
Thank you very much for the information ...
Faisal Posted 28 Feb 2021 08:20
  
Nice article ...
Faisal Posted 01 Mar 2021 14:35
  
Great info ...
Faisal Posted 02 Mar 2021 10:20
  
Very informative …
Ellechar Lv4Posted 16 Mar 2021 15:39
  
Very Nice Infoooooooooooooo!
Faisal Posted 19 May 2021 10:49
  
Nice guidance ...
Raza Islam Lv3Posted 26 Jul 2022 15:56
  
Thank you very much for the information.
Raza Islam Lv3Posted 29 Jul 2022 16:04
  
Thank you very much for the information

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Doc ID: 4213
Author: Sangfor_Siva
Updated: 2020-12-28 11:37
Version: