U-Key Unable To Be Detected In Adesk

|
  • 201
  • 8

Issue Description

U-key from bank unable to be detected in VM in VDI after plug into aDesk.

Handling Process

  • Tried to go to Device manager but unable to find the USB device.
  • Tried to install the U-key related driver and software, still shows unable to be detected.
  • Tried to plug in the USB to OTG port but still unable to be detected.


Root Cause

Some USB key required to do USB whitelist, so the virtual machine in VMP able to detect the USB devices.

Solution

  • Plug in the U-key to the physical PC.
  • Use Genius Chip or USB dev viewer to find the pid and vid used by the U-key.
  • Login into VDC, navigate to VDI options -> policy set -> Default policy set (select the policy that apply to the user’s VM).
  • Navigate to the Virtual Desktop -> USB Device Access -> USB device Whitelist/Blacklist.
  • Click on Add.
  • Insert the VID : PID format, and set the mapping permission to Allow.


8. After added, click OK.
9. Click on Save to save the policy.
10. Click apply to make the policy take effect.
11. User required to logout from the VDC account so the USB mapping can take effect.
Faisal Posted 23 Aug 2020 10:47
  
Thank you very much for the information ...
Muhammad Bilal Lv4Posted 29 Aug 2020 17:08
  
Thanks for sharing solution
Faisal Posted 21 Oct 2020 08:37
  
Nice article ...
Faisal Posted 21 Oct 2020 08:37
  
Nice article ...
Faisal Posted 20 Dec 2020 10:05
  
Great info ...
Ellechar Lv4Posted 22 Jan 2021 13:16
  
Very nice infoooooooooooooooooooooooooooooo
Faisal Posted 21 Mar 2021 08:02
  
Very informative …
Faisal Posted 06 Jun 2021 07:29
  
Nice guidance ...

I want to write a case
Doc ID: 2301
Author: Sangfor_Brando
Updated: 2019-12-22 16:35
Version: