HCI aDeploy Pre-Upgrade Check, Error Of "Status of devices connected to the VM NIC"

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Issue Description

Execute pre-upgrade check using aDeploy and prompted an alert of "Status of devices connected to the VM NIC" with description "Cause: Host 192.168.1.1 Devices connected to the NIC of the following VMs are missing: vmid (e.g. 1234567890)."

Error/Warning Information

Handling Process

1. Ensure the VM does exist, locate and access the VM's profile.
i. copy the vmid.

2. Access any VM's profile on the HCI WebUI console.
- replace the id=123456789 to the vmid copied in 1.i.
- and then refresh the website and it should redirect to the designated vmid's VM profile.

3. Edit the VM.

4. Connect any of the (1 NIC is enough) VM's NIC to any (unused or using) edge or vswitch, then click OK.
- after that, disconnect the NIC. (optional)


5. Execute pre-upgrade check again using aDeploy and now the alert should be resolved.

Root Cause

1. Previously connected virtual device has been deleted improperly.  

Solution

1. Refer to the handling process.

Suggestions

If the scenario varies from above or the solution doesn't work, kindly contact Sangfor technical support for further assistance.

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Doc ID: 7303
Author: CTI Chris
Updated: 2022-10-21 10:53
Version: