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1. Backgroud

1.1 Protocol support

Protocol Status
SMTP Y
POP Y
TLS/SSL Y
MAPI Y

1.2 Exchange version support

Server
Outlook

2003 2007 2010 2013 2016

2003 Y Y Y Y N
2007 Y Y Y Y N
2010 Y Y Y Y N
2013 Y Y Y Y N
2016 N N N N N
365 N N N N N

(This Explain from latest version 9.1R1, Nov.2015)

1.3 Things that customer need to prepare

According to the following scenarios, there is(are) 1-3 things need customer to prepare:
1. WANO use administrator account to join domain
2. Create a domain user for WANO and use this account delegate Exchange server

ExchangeMDB service
3. Import Exchange CA to WANO

Make sure customer prepare the above things in advance!
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2. Exchange Scenarios

Scenario 1 : Single Domain/ Centralized AD server/ Centralized Exchange

server/ Single Exchange server

Scenarios Single Domain/ Centralized AD server/ Centralized Exchange server/
Single Exchange server

Version requested 9.1SP1 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 Proxy
2 SMTP/POP3 over SSL 1. Import Exchange server certificate to WANO, configure

certificate IP as Exchange server IP, configure port as 0
2. Enable SMTP/POP3 Proxy

3 MAPI 1. WANO join domain
2. Create a domain user for WANO and use this account
delegate Exchange server ExchangeMDB service
3. Sync WANO time zone/date/time with AD, keep time differ in
30s, and then use delegation mode in exchange proxy.
4. Outlook anywhere need to import Exchange server certificate
to WANO , configure certificate IP as Exchange sever IP,
configure port as 0

4 WebMail 1. Import Exchange server certificate to WANO
2. Enable SSL proxy
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Scenario 2 : Single Domain/ Centralized AD server/ Centralized Exchange server

/ Exchange server cluster

Scenarios Single Domain/ Centralized AD server/ Centralized Exchange server /
Exchange server cluster

Version requested 9.1R1/9.3 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 Proxy
2 SMTP/POP3 over SSL 1. Import Exchange server certificate to WANO, configure

certificate IP as Exchange server IP, configure port as 0
2. Enable SMTP/POP3 Proxy

3 MAPI 1. WANO join Domain
2. Create a domain user for WANO and use this account
delegate all Exchange server ExchangeMDB service
3. Sync WANO time zone/date/time with AD, keep time differ in
30s, and then use delegation mode in exchange proxy.
4.outlookanywhere need to import Exchange server certificate
to WANO ,configure certificate IP as Cluster IP,configure port as
0

4 WebMail 1. Import Exchange server certificate to WANO , Certificate IP
set Cluster IP, port set 0
2. Enable SSL proxy
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Scenario 3 : Single Domain/ Centralized AD server/ Distributed Exchange server

/ Single Exchange server

Scenarios Single Domain/ Centralized AD server/ Distributed Exchange server /
Single Exchange server (Each Exchange server communicate and
sync to each other directly )

Version requested 9.1R1 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 proxy
2 SMTP/POP3 over SSL 1. Import Exchange1 certificate to WANO HQ, configure

Certificate IP as Exchange 1 server IP, configure port as 0
2. Import Exchange2 certificate to WANO Branch2, configure
certificate IP as Exchange2 IP, configure port as 0
3. Import Exchange3 certificate to WANO Branch3, configure
certificate IP as Exchange3 IP, configure port as 0
4. Enable SMTP/POP3 proxy

3 MAPI N/A
4 WebMail N/A
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Scenario 4 : Single Domain/ Centralized AD server/ Distributed Exchange server

/ Single Exchange server

Scenarios Multi site/ Single Domain/ Single AD/ Single Exchange (All branch
exchange sync to HQ exchange ,then HQ exchange sync to other
Exchange servers)

Version requested 9.1R1 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 proxy
2 SMTP/POP3 over SSL 1. Import Exchange1 certificate to WANO HQ, configure

certificate IP as Exchange1 IP, configure port as 0
2. Import Exchange2 certificate to WANO Branch2, configure
certificate IP as Exchange2 IP, configure port as 0
3. Import Exchange3 certificate to WANO Branch3, configure
certificate IP as Exchange3 IP, configure port as 0
4. Enable SMTP/POP3 proxy

3 MAPI N/A
4 WebMail N/A
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Scenario 5 : Single Domain/ Centralized AD server/ Distributed Exchange server

/ Exchange server cluster

Scenarios Multi site/ Single Domain/ Single AD/ Multi Exchange
Version requested 9.1R1/9.3 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 proxy
2 SMTP/POP3 over SSL 1. Import Exchange1/3 certificate to WANO HQ, configure

certificate IP as Cluster IP, configure port as 0
2.Import Exchange2 certificate to WANO Branch, Certificate IP
set Exchange2 IP, port set 0
3. Enable SMTP/POP3 proxy

3 MAPI N/A
4 WebMail N/A
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Scenario 6 : Single Domain/ Distributed AD server/ Distributed Exchange server/

Single Exchange

Scenarios Multi site/ Single Domain/ Multi AD/ Multi Exchange
Version requested 9.1R1 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 proxy
2 SMTP/POP3 over SSL 1. Import Exchange1 certificate to WANO HQ, configure

certificate IP as Excahnge1 IP, configure port as 0
2. Import Exchange2 certificate to WANO Branch, configure
certificate IP as Exchange2 IP, configure port as 0
3. Enable SMTP/POP3 proxy

3 MAPI N/A
4 WebMail N/A
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Scenario 7 : Multi Domain/ Centralized AD server/ Distributed Exchange

server/Exchange server cluster

Scenarios Multi site/ Multi Domain/ Single AD/ Multi Exchange
Version requested 9.1R1 or above

Item Email protocol
enabled

WANO configuration

1 SMTP/POP3 Enable SMTP/POP3 proxy
2 SMTP/POP3 over SSL 1. Import Exchange1 certificate to WANO HQ, configure

certificate IP as Excahnge1 IP, configure port as 0
2. Import Exchange2 certificate to WANO Branch, configure
certificate IP as Exchange2 IP, configure port as 0
2. Enable SMTP/POP3 proxy

3 MAPI N/A
4 WebMail N/A
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3. WANO exchange configuration

3.1 How to join domain

1. WANO Preferred DNS configure intranet DNS/AD IP.

2. Better use administrator account join domain
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3.2 How to use domain user delegate ExchangeMDB service

Configuration refer to:
https://WANO_IP/html/wanacc/help/us_es/Windows_Domain_Authenticatin_Configuration_Gui
de.htm
A. Add a user in domain
B. Install setspn on Windows. Insert the Windows 2003 installation CD into the computer. Open
the -SUPPORT—TOOLS and execute SUPTOOLS.MSI. To check whether setspn is installed
successfully, open cmd and execute setspn. This step is not needed for Windows 2008, for setspn
is already installed.
C. Create SPN (Service Principal Name). Open cmd and type the command: setspn -A
http/daserver weipai, among which, weipai is the user account created on the above step.

D. Grant user rights to delegate on domain controller.
1. In Windows, choose Start > Administrative Tools > Active Directory Users and computers to
open Active Directory Users and Computers.
2. Right-click on the user account weipai and select Properties > Delegation > Trust this user for
delegation to specified services only > User any authentication protocol, as shown in the
screenshot below. If the option Use Kerberos only is selected, decryption will fail.

3. Click Add > Users or Computers, and enter the computer name of Exchange or CIFS server.
4. Select CIFS/ExchangeMDB.
E. Configuring Delegation Options on WOC,Navigate to System > Network > Deployment >
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Windows Domain. Under the Delegation Options section, click the New button and configure the
following contents:

*In this part, WANO system date, time zone must the same with AD, time can't differ above 30s

3.3 How to export certificate from server and import it to WANO

Before accessing Exchange server by using Outlook that is configured Outlook Anywhere
(RPC over HTTPS), import the IIS SSL certificate onto the server-end WOC. For how to export
certificate from Exchange server, refer to the document IIS SSL Certificate Export Guide.
IIS SSL Certificate Export Guide refer to:
https://WANO_IP/html/wanacc/help/us_es/IIS_SSL_Certificate_Export_Guide.html

IIS SSL 
Certificate Export Guide.docx

A. On Exchange server, click Start > Run and enter mmc.exe into the Open field to open a MMC
window, as shown in the following figure:

B. Click File > Add/Remove Snap-In > Add and select the certificate and click Add; select a user
account and click Next; select Local Computer and click Finish and Close.

https://192.200.19.1/html/wanacc/wanacc_ssl.html
https://192.200.19.1/html/wanacc/help/us_es/IIS_SSL_Certificate_Export_Guide.html
https://192.200.19.1/html/wanacc/help/us_es/IIS_SSL_Certificate_Export_Guide.html
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C. Click Console Root/Certificates (Local Computer) > Personal > Certificate to unfold the server
certificate. Please note that the Issued By column shows the full machine name of the Exchange
server and Certificate Template column shows Web server. Right-click on the certificate and
select All Tasks and Export… to start the Certificate Export Wizard.

D. Select the option Yes, export the private key and Click Next.
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E. Select Personal Information Exchange –PKCS #12(.PFX) and Include all certificate in the
certification path if possible, and select Next.

F. Set password and click Next. Please remember the password, for it is required when this
certificate is imported to server-end WOC.
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G. Select a path to save the PFX file and click Next and Finish.

H. Log in to Web administrator console of the server-end WOC and navigate to WAN
Optimization > Certificates > Server Certificate. Enter the IP address and HTTPS port of the
Exchange server, select the option Importcertificate that contains key and import the pfx
certificate file saved in the above step. Enter the password and click OK.
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* Port 0 mean all port, if you can confirm the port ,you can specify.

3.4 How to configure Exchange proxy

Exchange proxy use accelerate from outlook to exchange server.
This Proxy used in Scenario 1/2, configuration refer to 3.1.1/3.1.2 4.1/4.2/4.3

* Only Win XP and 2003 server can use auto-negotiation mode, other all use Delegation mode.
Win7 and above WIN7 client default authentication is NTLMv2

3.5 How to configure SMTP/POP3 Proxy

This Proxy may used in all scenarios
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4. Troubleshooting

4.1. Join domain failed.

1. Make sure preferred DNS is domain server IP, and ping domain controller in the webconsole or
pshell, whether it can resolve the correct IP and ping success.
2. You can check health status, WANO will remind you.

4.2. Delegation failed.

1. server 2003 need install setspan,
We need to run command in cmd " setspn -A http/daserver delegation_user" and then we can see
delegation tab in user property.
2. WANO need ExchangeMDB service
3. Check health status

4.3. Check WAN Optimization logs
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Related Logs

Logs Description

Please enable NTLMv2 delegation NTLMv2 needs to be enabled on server-side WOC

Please enable client's ntlm authentication NTLM is not enabled on client PC

Please configure delegation user Delegation user needs to be configured (see the
section Adding Delegation User Account on WOC)

Please check delegation config Configuration is incorrect (see the sections Creating
Delegation User Account on DC or Configuring
Delegation Options on WOC)

Please check time between WOC and KDC Time sync between WOC and DC is required (see the
section Configuring System Time on WOC and
Domain Controller)

Please join WOC to the domain WOC needs to be joined to the domain

Use local user or other domain user, check domain
config

User is using local user account or not using
acceleration account access the Exchange or CIFS
server.

Please check delegation user's account and password Username or password is incorrect (see the section
Adding Delegation User Account on WOC)
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4.4. Capture packets from client to Exchange server, confirm the authentication.

Such as following packet, it use the kerberos authentication, so we need to use delegation mode
and not chose NTLMv2

4.5. Keep WANO time zone and time the same with Domain server, or use NTP

server to sync time.

4.6. Capture between Exchange ,confirm the SMTP/POP3 traffic whether over

SSL
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5. Real cases’ Report

5.1 MAPI

Customer: ZICO LAW use scenario 2, KEMP load balance, MAPI+SSL

Customer: Sangfor Malaysia support center use scenario 1
Test Repeat send same mail to different branch user
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5.2 SMTP/POP3

Customer: EP Polymer use scenario 1
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